Minimum Technical Requirements - ComplianceServe

The following are the minimum requirements for ComplianceServe:

Windows
  • Microsoft Internet Explorer 9 or later (not run in compatibility mode)
  • Google Chrome (latest version)
  • Mozilla Firefox  (latest version)
  • Safari  (latest version)

iPad
  • Safari 

Android
  • Chrome 
Please note that the above are in addition to the minimum requirements to the Unicorn LMS and ContentServe.

Feedback and Knowledge Base