Minimum Technical Requirements - Workplace Skills by Learning Heroes

The following are the minimum requirements for Workplace Skills by Learning Heroes:

Windows
  • Google Chrome (latest version)
Mac
  • Safari 7 or later
  • Google Chrome (latest version) 
iPad
  • Safari in Apple iOS 7 or later

Android
  • Google Chrome (latest version) in Android OS 4.1 and later

The following are the minimum requirements only if you are launching using Adobe Flash (requires 10.3 or later): 

Windows
  • Internet Explorer 8 or later
  • Microsoft Edge (latest version)
  • Google Chrome (latest version)
  • Firefox

Mac
  • Safari 7 or later
  • Google Chrome (latest version)
  • Firefox  

Please note that all of the above are in addition to the minimum requirements to the Unicorn LMS and ContentServe.  

Feedback and Knowledge Base