Minimum Technical Requirements - Essential Skillz

The following are the minimum requirements for Essential Skillz:

  • The EssentialSkillz content is tested on and they provide for support on Internet Explorer 8 and above on Windows Laptops and Desktops. 
  • They also test and support on tablet devices and browsers. EssentialSkillz do not support or test on other browsers or platforms (includes smartphones or Mac platforms). 

Please note that the above are in addition to the minimum requirements to the Unicorn LMS and ContentServe.  

Feedback and Knowledge Base